Dennis Kieselhorst

Merge pull request #571 from apache/CXF-7601_microProfileOpenApi

[CXF-7601] Add support for Microprofile OpenAPI implementation

update saaj-impl to ee4j release version

update saaj-impl to ee4j release version

Merge branch 'master' into CXF-7910_jakarta_jaxws-api

# Conflicts:

# parent/pom.xml

update maven-invoker-plugin version, now set in parent

    • -2
    • +1
    /maven-plugins/wadl2java-plugin/pom.xml
added source/ target for compiler plugin to fix testcase

[CXF-7906] update JAX-RS API to 2.1.5

update Tomcat version

    • -6
    • +0
    /systests/rs-sse/rs-sse-tomcat/pom.xml
update awaitility version

update undertow version

Recording .gitmergeinfo Changes

Recording .gitmergeinfo Changes

update rxjava, rxjava2 and projectreactor dependencies

[CXF-7947] avoid NPE for classes in default package

[CXF-7947] avoid NPE for classes in default package

(cherry picked from commit d9c0c2ffb468315c9e538736ac8e731782209640)

[CXF-7947] avoid NPE for classes in default package

(cherry picked from commit d9c0c2ffb468315c9e538736ac8e731782209640)

(cherry picked from commit d03dc931df389e7dbab72d1b1fb3ae5993f9c6f2)

update swagger-ui to latest version

update Spring, Spring Security, Spring Boot version

Revert "[CXF-7910] Change JAX-WS javax to jakarta artifact dependencies"

This reverts commit d49adb6a

Merge remote-tracking branch 'origin/master' into CXF-7910_jakarta_jaxws-api

# Conflicts:

# osgi/karaf/features/src/main/resources/features.xml

# parent/pom.xml

[CXF-7910] use jakarta.xml.soap-api and jakarta.jws-api

[CXF-7910] use jakarta.xml.soap-api and jakarta.jws-api

[CXF-7910] add temporary exclusion until cxf-xjc-runtime has been released

[CXF-7910] add temporary exclusion until cxf-xjc-runtime has been released

[CXF-7910] Change JAX-WS javax to jakarta artifact dependencies

[CXF-7910] add jakarta.xml.soap-api and jakarta.jws-api to fix OSGi errors, use existing cxf.specs.jaxws.api.version property

[CXF-7910] add jakarta.xml.soap-api and jakarta.jws-api to fix OSGi errors, use existing cxf.specs.jaxws.api.version property

[CXF-7910] use servicemix specs for 2.3

[CXF-7910] use servicemix specs for 2.3

[CXF-7910] Update SAAJ Impl to 1.4