Checkout
djh
committed
on 03 Dec 07
Make generated solution and project files compatible with VS2008 and
MSBuild 3.5 if the --vsnet-version=2008 option is used.

Patch by: Bert… Show more
Make generated solution and project files compatible with VS2008 and

MSBuild 3.5 if the --vsnet-version=2008 option is used.

Patch by: Bert Huijben <b.huijben@competence.biz>

* build/generator/gen_vcnet_vcproj.py

 Check for new version and use VS2005 solution template

* build/generator/gen_win.py

 Allow more versions and set solution and project version for VS2008

 Fixed a typo in the error case

* build/generator/vc2005_sln.ezt

 Updated to insert "2005" or "2008" based on the selected version.

* gen-make.py

 Updated --help documentation

Show less