Checkout
James McCoy
committed
on 17 Feb
Require at least version 1.5 of APR

Since r1874057, the apr_pescape_shell() API is being used to escape filenames
when invoking $SVN_EDITOR… Show more
Require at least version 1.5 of APR

Since r1874057, the apr_pescape_shell() API is being used to escape filenames

when invoking $SVN_EDITOR.  This was added to APR in 1.5.0, released on

2013-11-13.

* INSTALL

 (): Document new minimum APR version

* build/generator/gen_win_dependencies.py

 (_find_apr): Bump minimal_apr_version to 1.5.0

* configure.ac

 (APR_VER_REGEXES): Bump minor version in 1.x regex to 1.5

* get-deps.sh:

 (APR_VERSION): Specify 1.5.0 as default version

* subversion/include/private/svn_dep_compat.h

 (apr_time_from_msec): Removed, since it's provided by APR 1.4.0 or later

* subversion/include/svn_types.h

 (apr_hash_this_key, apr_hash_this_key_len, apr_hash_this_val): Remove

  prototypes, since they're provide by APR 1.5.0 or later

* subversion/libsvn_subr/iter.c

 (hash_do_baton): Remove condition requiring APR 1.4.0 to define this type

 (svn_iter_apr_hash): Remove pre-APR 1.4.0 code

 (apr_hash_this_key, apr_hash_this_key_len, apr_hash_this_val): Remove

  definitions, since they're provided by APR 1.5.0 or later

* subversion/libsvn_subr/pool.c

 (apr_pool_create_unmanaged_ex): Remove conditional alias to

  apr_pool_create_core_ex, for APR versions < 1.3.3

Show less