Checkout
Bert Huijben
committed
on 05 Jul 12
Make the upgrade from entries capable of upgrading to conflict skels.

This resolves the last 2 test failures when running with conflict ske… Show more
Make the upgrade from entries capable of upgrading to conflict skels.

This resolves the last 2 test failures when running with conflict skels.

* subversion/libsvn_wc/entries.c

 (includes): Add conflicts.h.

 (insert_actual_node): Add db and wri_abspath arguments to allow using the

   conflict api. Check all columns like in other places.

   Add conflict skel implementation.

 (write_entry,

  write_actual_only_entries,

  svn_wc__write_upgraded_entries): Update caller.

Show less