Checkout
Mathieu Lirzin
committed
on 19 Oct
Fixed: Make ‘javadoc’ build work with recent Java
(OFBIZ-11257)

With a recent OpenJDK release we had the following error

```
> Task :javad… Show more
Fixed: Make ‘javadoc’ build work with recent Java

(OFBIZ-11257)

With a recent OpenJDK release we had the following error

```

> Task :javadoc

javadoc: error - The code being documented uses modules but the packages defined in https://docs.oracle.com/javase/8/docs/api/ are in the unnamed module.

javadoc: error - The code being documented uses modules but the

packages defined in https://docs.oracle.com/javaee/7/api/ are in the

unnamed module.

[...]

2 errors

100 warnings

> Task :javadoc FAILED

```

With ‘javadoc --source 8’ this error disappears as described in

JDK-8212233 [1].

[1] https://bugs.openjdk.java.net/browse/JDK-8212233

Show less