Clone Tools
  • last updated 27 mins ago
Constraints: committers
Constraints: files
Constraints: dates
Improved: Corrected all redundant modifiers occurences in framework component. Also, fixed some other checkstyle line formatting and spacing issues. (OFBIZ-11925)

  1. … 59 more files in changeset.
Improved: Corrected some line is longer than 150 characters checkstyle issues in framework component. Also fixed some extra spaces and naming conventions related checkstyle issues. (OFBIZ-11921)

  1. … 117 more files in changeset.
Improved: Corrected all checkstyle formatting issues: 'typecast' is not followed by whitespace in framework component. (OFBIZ-11887)

  1. … 86 more files in changeset.
Improved: Corrected all checkstyle formatting issues: Line has trailing spaces in framework component. (OFBIZ-11880) Thanks Jacques for review.

  1. … 96 more files in changeset.
Improved: Corrected checkstyle formatting issues, 'is preceded/not preceded with whitespace' for framework component. (OFBIZ-11874) This fixes following checkstyle issues: '{' is not preceded with whitespace. '{' is not followed by whitespace. '}' is not followed by whitespace. '}' is not preceded with whitespace. 'typecast' is not followed by whitespace. 'try' is not followed by whitespace. ';' is preceded with whitespace.

  1. … 159 more files in changeset.
Improved: Corrected all checkstyle issues related to succeeding space for comma in framework directory. (OFBIZ-11805) Thanks Jacques and Ritesh Kumar for review.

  1. … 33 more files in changeset.
Improved: Merge identical catch blocks in single catch block(OFBIZ-11827)

In Java SE 7 and later, a single catch block can handle more than one type of exception. This feature can reduce code duplication and lessen the temptation to catch an overly broad exception.

Thanks: Jacques for the review.

  1. … 51 more files in changeset.
Improved: Replace single method call lambda with method reference(OFBIZ-11835)

Thanks: Jacques for the review.

  1. … 5 more files in changeset.
Improved: Made MODULE as private data member of class instead of public in all framework components. (OFBIZ-11739) This will reduce checkstlye issues. Thanks Jacques for review.

  1. … 395 more files in changeset.
Documented: Framework, migration all docbook files to asciidoc (OFBIZ-11587)

- common-sending-email: include in email

- datafile: move as a include at the end of entity-engine section

- entity-engine: list of link to OFBiz wiki about entity configuration

- service-engine: a link to OFBiz wiki Service Engine Guide

- webtools: help for main screen

- mini-lang: include a link to OFBiz wiki mini-lang-reference at the

beginning of minilang-to-groovy-manual

move minilang-to-groovy-manual to Development environment


- unit-test: include as Junit test, and use README to list gradle

command available (so add a tag in REAME.adoc)

- base: add a link to OFBiz wiki Configuration Guide, in deployment


- SingleSignOn with LDAP: move to plugin LDAP and include in deployment


developer-manual is updated with some include lines or with directly a


    • -0
    • +159
    • -0
    • +155
  1. … 9 more files in changeset.
Improved: replaces module by MODULE everywhere

  1. … 679 more files in changeset.
Reverted: "Improved: Use ‘depends-on’ attribute instead of “component-load.xml”" (OFBIZ-11296)

This reverts commit eeabe69813a1d9f42911dec70a912574046ef49b.

  1. … 24 more files in changeset.
Improved: Use ‘depends-on’ attribute instead of “component-load.xml” (OFBIZ-11296)

We currently have two ways to define component loading order. Either

by using ‘depends-on’ attribute in “component-config.xml” or by adding

a “component-load.xml” file at the root of a component directory.

“depends-on” is more flexible because it handles partial ordering when

“component-load.xml” defines a total order which is not necessarily

meaningful, so it is better to rely only “depends-on”.

This removes the usage of “component-load.xml” to use ‘depends-on’

instead. The dependency declarations correspond to the total ordering

previously defined but will need to be refined in the future to relax

unnecessary dependency declarations.

Only “framework/base/config/component-load.xml” which defines the

top-level directories order (framework, applications, themes and

plugins) is kept.

  1. … 24 more files in changeset.
Improved: Remove unused imports

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 1 more file in changeset.
Improved: Remove redundant "dtd" directory from classpath (OFBIZ-11161)

the "dtd" directories are already present as resources distributed

inside OFBiz jar, so there is no need to augment the classpath to find

the XML schema inside those directories.

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 10 more files in changeset.
Improved: Remove useless ‘GroovyScriptTestCase’ (OFBIZ-11165)

This class was useless since ‘GroovyScriptTestCase’ provides the same

interesting feature as ‘OFBizTestCase’ meaning a delegator and a dispatcher.

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 15 more files in changeset.
Improved: Inline ‘UtilGenerics#checkList’ (OFBIZ-11141)

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 84 more files in changeset.
Improved: Add missing ‘static’ modifier for private methods (OFBIZ-11098)

In order to make it clear when a method is not depending on the

internal state of an object, it is a good practice to declare it as


git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 41 more files in changeset.
Improved: Use the ‘@Override’ annotation (OFBIZ-10939)

The ‘@Override’ annotation helps readers understand that the method at

hand is overriding a super class or implementing an interface.

Additionally it allows the compiler to check if the methods annotated

with ‘@Override’ are actually implementing an abstract method.

Using that annotation makes ‘@see’

comments useless, so those they have been removed for the newly

annotated methods.

Thanks Jacques Le Roux and Swapnil M Mane for acknowledging the commit.

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 168 more files in changeset.
Improved: Remove unnecessary declared exceptions for ‘ContainerException’ (OFBIZ-10938)

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 7 more files in changeset.
Improved: Remove redundant specification of type arguments (OFBIZ-10937)

Since Java 1.7, when defining generic types it is unnecessary to

redefine those types in the constructor when it is done in the

declared type.

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 237 more files in changeset.
Improved: Disallow alternate test dispatcher/delegator (OFBIZ-10723)

Previously the way integration tests were run allows having a specific

dispatcher and delegator for each test. Removing this feature helps

future simplification of the way integration tests are actually run by

allowing the algorithm to assume only one dispatcher and delegator for

all the tests.

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

Improved: Fix or Silence various warnings (OFBIZ-10701)

In order to detect potential issues early, the linting compiler option should be

used by default and disabled with {{./gradlew -PXlint:none build}}.

Additionally it is important to reduce the number of warnings otherwise new

warnings will remain unnoticed.

The warning related to the com.googlecode.concurrentlinkedhashmap dependency

should resolves itself once we handle upgrade to Caffeine like proposed in


Thanks: Mathieu Lirzin

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 128 more files in changeset.
Improved: Clean some Groovy files in base component (OFBIZ-10646)

Following discussion at

this cleans some Groovy files in the base component, notably:

* remove ant-scripts folder and its content.

* Rename framework/base/groovyScript to framework/base/groovyScripts;

* Move GroovyInit.groovy and GroovyServiceTest.groovy respectively to

framework/base/groovyScripts and framework/common/groovyScripts

and change their paths where used.

* Removes GroovyInit.groovy from excludedConfigFiles in build.gradle

* After OFBIZ-10611 it's possible to move GroovyBaseScript.groovy from




* Removes FileUtilTests.groovy from basetests.xml (missed it in OFBIZ-10611)

* Fixes a typo in test-suite.xsd

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 13 more files in changeset.
Improved: complete previous commit to add security in groovy context (OFBIZ-10196) add security on groovy junit test add security on eclipse and intellij groovy dsl definition Thanks to Dennis Balkir for the suggest

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 3 more files in changeset.
Fixed: forget to add the class ans the simple groovy test-suite in the previous commit related to issue OFBIZ-9996 Correct introduced typo in framework/testtools/dtd/test-suite.xsd

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 1 more file in changeset.
Implemented: Implement Groovy test in testtools (OFBIZ-9996)

With the minilang deprecation and the migration to groovy, I implemented on the ofbiz testtools the possibility to use groovy for write new integration test or convert current simple xml test.

Now you can define a new element as child of test-group on your xml test-suite file like

<groovy-test-suite name=simple location=component://base/groovyScript/test/SimpleTests.groovy/>

To Write your test, you need to create a Groovy class that extends GroovyScriptTestCase class :

import org.apache.ofbiz.testtools.GroovyScriptTestCase

class BaseTest extends GroovyScriptTestCase {

void testTrue() {

assert 1, 1



All your function will execute as TestCase.

For more information on groovy specific testing language see

At this time the OFBiz Groovy DSL isn't supported to write groovy test case but you have access to the delegator and the disphatcher as native class variable.

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 1 more file in changeset.
Refactor OFBiz containers and remove StartupCommandToArgsAdapter (OFBIZ-9441)

A major refactoring patch that applies the following changes:

- Fully refactor the EntityDataLoadContainer

- Fully refactor the TestRunContainer

- In both above mentioned containers the logic is broken up into smaller

methods to enhance code readability. It also changes the signature of

the method calls to rely on StartupCommand instead of String[] arrays

- Remove most old documentation and commented out code where applicable

- Delete the StratupCommandToArgsAdapter as it is no longer needed

- Create a new feature in which OFBiz by default fails if any data file

fails to load. This can be overridden by passing a flag called

"continue-on-failure" e.g. ./gradlew "ofbiz --load-data continue-on-failure"

- Add a new property to --test called "loglevel" (old code but working properly)

- Add many new properties to the --load-data command including repair-columns,

try-inserts, maintain-txs, etc ... These properties are old, but somehow

did not make it into the command line arguments. This code is now exposed

through the command line to set a direction in the future of whether to

keep or delete these extra commands

- Update the documentation output of ./gradlew "ofbiz --help" to incorporate

the new mentioned properties

- Refactor to incorporate the changes to the gradle commands for both

"-load-data" and "-test" properties. Also remove the gradle GUI

documentation as it is now deprecated.

- Also refactor in other locations to cleanup and make it more

consistent. This icludes moving long notes into new sections and reducing

the verbosity of the security header. Furthermore, created a new header

called Miscellaneous documentation to house the newly created sections

- lots of small changes to remove EOL white space

Thanks: Jacques Le Roux for reviewing and testing

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 8 more files in changeset.
Improved: [DEPRECATION] Replace BigDecimal.ROUND_* by RoundingMode.* (OFBIZ-9571)

No functional change.

We read at :

<<Using the integer fields in this class (such as ROUND_HALF_UP) to represent

rounding mode is largely obsolete; the enumeration values of the RoundingMode

enum, (such as RoundingMode.HALF_UP) should be used instead.>>

That's an easy global replacement. But it also needs to import the RoundingMode

class. It was 26 files so I decided to rather clean all the imports in all files

with the help of Eclipse.

This is a 1st step. I will need to closely look at 2 special class: UtilNumber

and Calculate.

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 165 more files in changeset.
Improved: Refactor and simplify the startup sequence in OFBiz (OFBIZ-8337)

Continuing the refactoring work on the startup sequence, this commit

specifically focuses on the ComponentContainer and how it loads

components into the system. The following changes are made:

- simplify and cleanup the ofbiz-containers.xml to have only one entry

- substantially simplify the ComponentLoaderConfig class and remove unnecessary defined state

- delete the JustLoadComponentsContainer (used to exist for the server command --testlist which no longer exists)

- fully refactor the ComponentContainer class and breakup the messy logic into chunks of private methods. The methods are also properly documented.

- remove an old reference to the testlist container which no longer exists

git-svn-id: 13f79535-47bb-0310-9956-ffa450edef68

  1. … 4 more files in changeset.