Checkout
Christophe Jaillet
committed
on 03 Mar 19
Fix a parsing error when using Ant 1.9.13 without the external Xerces (2.9.0) and Xalan (2.7.1).

The error is: "filter-expr(funcall(curren… Show more
Fix a parsing error when using Ant 1.9.13 without the external Xerces  (2.9.0) and Xalan (2.7.1).

The error is: "filter-expr(funcall(current, []), [pred(=(step("attribute", 39), literal-expr(section)))])'. Cause: Erreur lors de la vérification du type de l'expression 'filter-expr(funcall(current, []), [pred(=(step("attribute", 39), literal-expr(section)))])"

This takes us 1 step closer to use Ant 1.9+ and remove Xerces and Xalan from the build chain.

Patch tested with the current doc build chain (Ant 1.6.5 + Xerces + Xalan) on the 2.4.x branch.

Even if actually we don't have any "<Foo>" and "Foo" directives, I've checked that the doc is built correctly in such a case. Show less