Checkout Tools
  • last updated 1 hour ago
Constraints: committers
Constraints: files
Constraints: dates

Changeset 1634529 is being indexed.

Merge r1629372, r1629485, r1629519 from trunk:

Move OCSP stapling information from a per-certificate store

(ex_data attached to an X509 *) to a per-server hash which is

allocated from the pconf pool. Fixes PR 54357, PR 56919 and

a leak with the certinfo_free cleanup function (missing


* modules/ssl/ssl_util_stapling.c: drop certinfo_free, and add

ssl_stapling_certid_free (used with apr_pool_cleanup_register).

Switch to a stapling_certinfo hash which is keyed by the SHA-1

digest of the certificate's DER encoding, rework ssl_stapling_init_cert

to only store info once per certificate (allocated from the pconf

to the extent possible) and extend the logging.

* modules/ssl/ssl_private.h: adjust prototype for

ssl_stapling_init_cert, replace ssl_stapling_ex_init with


* modules/ssl/ssl_engine_init.c: adjust ssl_stapling_* calls

Based on initial work by Alex Bligh <alex>

Follow up to r1629372: ensure compatibily with OpenSSL < 1.0 (sk_OPENSSL_STRING_value).

Follow up to r1629372 and r1629485: ensure compatibily with OpenSSL < 1.0 (sk_OPENSSL_STRING_[num|value|pop] macros).

Submitted by: kbrand, ylavic, ylavic

Reviewed/backported by: jim

  1. … 6 more files in changeset.
Merge r1633730 from trunk:

add OCSP Stapling configuration, disabled by default

Submitted by: trawick

Reviewed/backported by: jim

  1. … 3 more files in changeset.
Merge r1621367, r1621372, r1625952 from trunk:


Allow for longer worker names and make truncation a non-fatal


Correct loglevel.

oops... prepend 0

Reviewed/backported by: jim

  1. … 4 more files in changeset.
Merge r1597642, r1608999, r1605207, r1610366, r1610353, r1611871 from trunk:

Rename module name in doxygen + partly revert r832442 which skipped doxygen doc generation for 'mod_watchdog.h'

s/apr_pstrndup/apr_pstrmemdup/ to save a few cycles

Use ap_remove_input_filter_byhandle instead of duplicating the code.

Remove some 'register' in variable declaration.

Remove some 'register' in variable declaration.

Save a few cycles by calling 'apr_isalnum' instead of 'apr_isalpha' and 'apr_isdigit'.

Do not use deprecated define.

No change in generated code because MODULE_MAGIC_NUMBER is defined as:


Submitted by: jailletc36

Reviewed/backported by: jim

  1. … 12 more files in changeset.
Merges some corrections from trunk

fix broken references

  1. … 28 more files in changeset.
backport: Tidy up examples
  1. … 1 more file in changeset.
backport whitespace/newline changes to 2.4
  1. … 3 more files in changeset.
Backporting syntax highlighting for rewrite/
  1. … 14 more files in changeset.