httpd

Checkout Tools
  • last updated 3 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates

Changeset 1853956 is being indexed.

mod_proxy_http: revert spurious comment from r1853953.

No, if we read more bytes than the C-L there is really something wrong in

our (or some) HTTP input filter.

votes
mod_proxy_http: common function for stream_reqbody_{cl,chunked}()

Since stream_reqbody_cl() and stream_reqbody_chunked}() now have the same

structure, join them into a single stream_reqbody() function which is passed

the rb_method to handle only CL vs chunked cases differently.

Propose.
Follow up to r1853874: CHANGES entry.
mod_reqtimeout: follow up to r1853901: init stage name outside INIT_STAGE().

It helps both code readability where stages are initilized and potential

logging in the input filter (even if the stage is disabled).

mod_reqtimeout: follow up to r1853901: fix macro args.

mod_reqtimeout: follow up to r1853906: adjust hooks priorities comments.

mod_reqtimeout: Allow to configure (TLS-)handshake timeouts.

The timeouts apply between the process_connection and pre_read_request hooks.

They are disabled by default for compatibily reasons.

mod_reqtimeout: factorize structs and code.

With a bit of macro magic, this is to avoid more code duplication when adding

new stages (next commit will add TLS/handshake timeouts handling in addition to

existing header and body ones).

No functional change here.

mod_cache_socache: avoid pool to heap reallocation.

Below some threshold, the previous code tried free (sub-)pooled memory ASAP by

moving small buffers (< capacity / 2) to a heap bucket. But this is not really

an optimization because first it requires at some point to allocate more than

the configured capacity, and second since this happens during response handling

the pool is about to be destroyed soon anymay.

This commit simply keeps the data in the subpool and uses a pool bucket for the

output brigade to take care of the lifetime until it's consumed (or not).

This is harmless, but this really should be an 'echo_do *'
Follow up of r1853689.

Remove the jar files.

    • ?
    /docs-build/trunk/lib/jakarta-oro.jar
Remove the jakarta-oro regex engine because:.

- it is retired since 2010-09-01 [1] and the use of regex feature from java is encouraged [2].

- Ant also considers that the Java's built-in regex package is likely the best choice going forward. [3]

- Built-in regex package is available in Java since 1.4 (Feb 2002) [4].

This has been discussed in [5] and the consensus was to upgrade and simplify our framework.

According to my testing, the doc generated with the built-in parser or the oro parser are identical. (tested on Ubuntu 18.10, OpenJDK 1.8.0)

[1]: https://attic.apache.org/projects/jakarta-oro.html

[2]: http://jakarta.apache.org/oro/

[3]: https://ant.apache.org/manual/Types/regexp.html#implementation

[4]: https://en.wikipedia.org/wiki/Java_version_history#J2SE_1.4

[5]: https://lists.apache.org/thread.html/305487e28daff15b4f16e876b8fe56ba3ca95fd39853cf26b7170d1d@%3Cdocs.httpd.apache.org%3E

- Be consistent with the case used for uniqueMember.

- Be consistent with the case used for AuthLDAPURL. Use uppercase URL, as in the code in order to fix syntax highlight issues.

- Fix the case of AuthLDAPSubGroupAttribute in <default>, so that quickreference.xsl works as expected

Fix some other small layout issues.

(r1853664 in trunk)

- Be consistent with the case used for uniqueMember.

- Be consistent with the case used for AuthLDAPURL. Use uppercase URL, as in the code in order to fix syntax highlight issues.

- Fix the case of AuthLDAPSubGroupAttribute in <default>, so that quickreference.xsl works as expected

Fix some other small layout issues.

Remove backported proposal
Merge r1850835, r1851552 from trunk

* mod_authn_dbm: clarify returned value (no fuctional change)

Submitted by: jorton, wrowe

Reviewed by: jailletc36, jim, ylavic

Backported by: jailletc36

Merge r1851093 from trunk

* mod_proxy_wstunnel: Fix websocket proxy over UDS.

PR: 62932

Submitted by: <pavel dcmsys.com>

Reviewed by: jailletc36 (by inspection), jim, ylavic

Backported by: jailletc36

Fix compatibility note, 'SSLPolicy' is not in 2.4.x yet.

+ remove a trailing space to synch with 2.4.x

Add directive name, so that quickreference.xsl can extract default value correctly.

Always align on the left code in <highlight> block in order to be consistent and fix a layout issue.

Add some links between directives.

(r1853637 in trunk)

+ remove some trailing spaces

+ improve an example to have it more simple (r1816989 in trunk)

to synch with trunk

Add directive name, so that quickreference.xsl can extract default value correctly.

Always align on the left code in <highlight> block in order to be consistent and fix a layout issue.

Add some links between directives.

* modules/md/mod_md_config.c (md_mod_conf_get): Use state-dir-relative

default base_dir.

Backport r1852478 to fix some typo in <syntax>

+ tweak mod_privilege to synch with trunk

Add directive name, so that quickreference.xsl can extract default value correctly.

Add a summary and explain at which loglevel the module operates. (related to PR 59088)

r1827780, r1853624 in trunk

Add directive name, so that quickreference.xsl can extract default value correctly.
Fix the directive name used in <default> syntax for DefaultRuntimeDir.

Add some links.

Fix case in directive name, so that quickreference.xsl can extract default value correctly.

Add a note in ThreadsPerChild about the relationship with ThreadsLimit

r1838958, r1853617 and r1853618 in trunk

Fix typo added in r1838958
Fix case in directive name, so that quickreference.xsl can extract default value correctly.