flex-sdk

Clone Tools
  • last updated 29 mins ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Merge changes from develop branch (rev 1422924)

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1423207 13f79535-47bb-0310-9956-ffa450edef68

Change AIR path from 3.1 to 3.4 added links to other versions of the Flash Player playerglobal.swc

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1423200 13f79535-47bb-0310-9956-ffa450edef68

In README, change min ant version to 1.7.1 since this is required by the Apache batik build.xml file (fileset errormissingdirectory attribute) and add instructions for building the RSLs. Fix the two scripts to check for the RSLs directory and add the RSLs requirement to the header comment.

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1423021 13f79535-47bb-0310-9956-ffa450edef68

Regenerated baselines due to font changes

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422983 13f79535-47bb-0310-9956-ffa450edef68

Updated README to for readability. Included section on convenience binaries and SDK installer.

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422924 13f79535-47bb-0310-9956-ffa450edef68

removed unneeded single space

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1422756 13f79535-47bb-0310-9956-ffa450edef68

optimistically removing the incubator disclaimer and "incubator" from the release path names

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1422755 13f79535-47bb-0310-9956-ffa450edef68

merged changes from develop branch so that apache.swc compiles containing expected classes

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1422687 13f79535-47bb-0310-9956-ffa450edef68

FLEX-33298 Fixed The apache lib compile without including anything

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422517 13f79535-47bb-0310-9956-ffa450edef68

Reapplied the textLayout modification

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422477 13f79535-47bb-0310-9956-ffa450edef68

added the experimental.dir property

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422472 13f79535-47bb-0310-9956-ffa450edef68

Removed the unnescessary external classes as they are now in the spark-manifest.xml

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422471 13f79535-47bb-0310-9956-ffa450edef68

    • -2
    • +27
    /frameworks/experimental-manifest.xml
Removed the unnescessary external classes as they are now in the spark-manifest.xml

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422470 13f79535-47bb-0310-9956-ffa450edef68

FLEX-33284 New Spark Components - the png inclusion is not needed

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422465 13f79535-47bb-0310-9956-ffa450edef68

FLEX-33284 New Spark Components

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422464 13f79535-47bb-0310-9956-ffa450edef68

FLEX-33284 New Spark Components

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422463 13f79535-47bb-0310-9956-ffa450edef68

FLEX-33284 New Spark Components

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422462 13f79535-47bb-0310-9956-ffa450edef68

    • -0
    • +48
    /frameworks/projects/experimental/spark-manifest.xml
  1. … 21 more files in changeset.
Updated paths to FP 11.3 and AIR 3.4. Don't think this file is used so it can be removed.

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1422455 13f79535-47bb-0310-9956-ffa450edef68

Update AIR to be version 3.4 from 3.1

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1422451 13f79535-47bb-0310-9956-ffa450edef68

fix issue with lib directory causing ant clean and ant super-clean to fail

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1422401 13f79535-47bb-0310-9956-ffa450edef68

merge rev 1422140 to develop branch

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422148 13f79535-47bb-0310-9956-ffa450edef68

Fix regression from new styles-as-data. It appears that StyleModules don't actually use their own StyleManager to host their styles.

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1422140 13f79535-47bb-0310-9956-ffa450edef68

Regenerated baselines to account for new fonts. Modified test code to account for tests running in the emulator.

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422078 13f79535-47bb-0310-9956-ffa450edef68

  1. … 54 more files in changeset.
Add apache.swc and experimental.swc to the binary kit and remove debug msg from automation_agent/build.xml. makeApacheFlexForFlashBuilder.sh works fine with the binary kit if these missing swcs are kitted.

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1422037 13f79535-47bb-0310-9956-ffa450edef68

merge rev 1421998 to develop branch

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1422033 13f79535-47bb-0310-9956-ffa450edef68

fix text truncation breakage

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1421998 13f79535-47bb-0310-9956-ffa450edef68

For the compile target, set javac source and target options to 1.6. This will allow us to use FlashBuilder 4.7 with the SDK when the compiler is built with Java 1.7 since FB supports Java 1.6 but not 1.7. All the other compiler modules set these javac options to either 1.4 or 1.5.

I chose 1.6 to avoid many warnings of this style:

warning: as of release 5, 'enum' is a keyword, and may not be used as an identifier

but this should be ok since we require a minimum of Java 1.6 according to our README.

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1421944 13f79535-47bb-0310-9956-ffa450edef68

    • -4
    • +13
    /modules/thirdparty/batik/build.xml
Add target to build textLayout_rb.swc.

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/release4.9@1421915 13f79535-47bb-0310-9956-ffa450edef68

These probably shouldn't be checked in.

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1421677 13f79535-47bb-0310-9956-ffa450edef68

Fix some mustella tests

git-svn-id: https://svn.apache.org/repos/asf/incubator/flex/sdk/branches/develop@1421673 13f79535-47bb-0310-9956-ffa450edef68