spi-fly-dynamic-framework-extension

Checkout Tools
  • last updated 4 months ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
[maven-release-plugin] prepare for next development iteration
  1. … 6 more files in changeset.
[maven-release-plugin] prepare release spifly-1.2.1
  1. … 6 more files in changeset.
ARIES-1901 Spi Fly not properly handling multiple providers described in the same descriptor as services
  1. … 4 more files in changeset.
[maven-release-plugin] prepare for next development iteration
  1. … 6 more files in changeset.
[maven-release-plugin] prepare release spifly-1.2
  1. … 6 more files in changeset.
ARIES-1859 source of org.apache.aries.spifly.dynamic.bundle on maven isn't complete

Signed-off-by: Raymond Auge <rotty3000@apache.org>

  1. … 2 more files in changeset.
ARIES-1857 Regression in framework.extension due to work on ARIES-1739

Signed-off-by: Raymond Auge <rotty3000@apache.org>

ARIES-1739 Specifiying a version in Require-Capability prevents registration

Signed-off-by: Raymond Auge <rotty3000@apache.org>

  1. … 10 more files in changeset.
[maven-release-plugin] prepare for next development iteration
  1. … 6 more files in changeset.
[maven-release-plugin] prepare release spifly-1.1
  1. … 6 more files in changeset.
ARIES-1844 Support for ASM 7 (Java 11)

Signed-off-by: Raymond Auge <rotty3000@apache.org>

  1. … 7 more files in changeset.
ARIES-1855 Finish removing legacy of LogService

Signed-off-by: Raymond Auge <rotty3000@apache.org>

  1. … 7 more files in changeset.
ARIES-1854 Add support for ServiceLoader.load(Class, ClassLoader)

Signed-off-by: Raymond Auge <rotty3000@apache.org>

  1. … 19 more files in changeset.
[maven-release-plugin] prepare for next development iteration
[maven-release-plugin] prepare release org.apache.aries.spifly.dynamic.framework.extension-1.0.14
update spifly poms
  1. … 6 more files in changeset.
[spifly] the framework extension can only work on a framework >= R7

Do this so the imported packages are of the right version

Signed-off-by: Raymond Auge <rotty3000@apache.org>

[spifly] add ignores to framework extension
[spifly] slim it down & eliminate warnings

Signed-off-by: Raymond Auge <rotty3000@apache.org>

ARIES-1814 Solve the start order limitations with SPI Fly by first creating a framework extension

Signed-off-by: Raymond Auge <rotty3000@apache.org>

  1. … 1 more file in changeset.