archiva

Clone Tools
  • last updated 13 mins ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
add generics

destroy context on close

use new log4j 2 configuration format

    • -0
    • +33
    /archiva-cli/src/main/resources/log4j2.xml
remove commented dependency

add missing dependency

remove wagon manager hack

Should no longer be needed since moving to Maven 3 project API

ensure archiva-cli is able to run

clean up the dependencies used and add some missing configuration form shade

split out problem facet

this avoids modules wanting to report a problem from having to depend on the

plugin itself and its consumer, etc.

fix scan location

fix package declarations

avoid duplicating classes in the produced bundle

merge artifact-converter into converter

Large amount of duplicated information and an unnecessary split package

caused duplicates in the produced bundle

  1. … 87 more files in changeset.
no longer needed

ensure archetype builds on a clean repository

Need to line up several dependencies that got managed differently, and trim

out things no longer needed. This could use a diet in general - there should

not be very much of Archiva's API or dependencies needed to build and test a

consumer.

remove antrun only used for echo

trim POM to required resources

must also populate variables

[MRM-1853] On first start up, you get a perpetual loading indicator. Submitted by Robert David

revert as was bad configuration in Jenkins sonar plugin

force sonar version

last parent for sonar plugin

use last cxf 2.6.x version

commons logging 1.2

log4j2 2.0

line ending

    • -65
    • +65
    /archiva-docs/src/site/apt/adminguide/legacy.apt
  1. … 31 more files in changeset.
[maven-release-plugin] prepare for next development iteration

  1. … 56 more files in changeset.
[maven-release-plugin] prepare release archiva-2.1.0

  1. … 56 more files in changeset.
use a staged released parent

tomcat 7.0.54

add corigin/archiva-1.3.x

    • -0
    • +1
    /archiva-docs/.gitignore
1.7 mandatory with 2.1.0