As part of internal API cleanup, and in the name of code clarity, rename svn_wc__db_status_absent to svn_wc__db_status_unauthz (not authorized), because this is what 'absent' really means. Now there is less potential for confusing 'absent' with 'not-present' and 'excluded'.
Discussed on IRC with Julian and Bert (not on dev@, but I still wanted to mention that this wasn't just my own idea).
We considered postponing this step to post-1.7 but Bert pointed out that doing so would unnecessarily make backport merges harder. But note that this does not rename all occurrences of the term 'absent' so we'll have to live with historical baggage in some function names, comments, etc.
Neither does this change the wc.db schema. But I think it would be good to rename the NODES presence value "absent" to "unauthz" as well in a separate step (including a format bump).
Suggested by: julianfoad (the new name 'unauthz')
* subversion/include/private/svn_wc_private.h (svn_wc__node_is_status_absent): Rename to... (svn_wc__node_is_status_unauthz): ... this, and rename the 'is_absent' output parameter to 'is_unauthz'.
* subversion/libsvn_wc/wc_db.c (wq_fetch_next_baton_t): New struct. (wq_fetch_next): New function. (svn_wc__db_wq_fetch): Rename to ... (svn_wc__db_wq_fetch_next): ... this and call wq_fetch_next, inside a transaction to fetch and complete items. (svn_wc__db_wq_completed): Remove function.
* subversion/libsvn_wc/wc_db.h (svn_wc__db_wq_fetch): Rename to ... (svn_wc__db_wq_fetch_next): ... this and update documentation.