As a follow-up to r1138871, rename status_unauthz again (formerly status_absent), this time to status_server_excluded.
See for related discussion this post and follow-ups: From: C. Michael Pilato To: dev@ Subject: Re: svn commit: r1138871 - in /subversion/trunk/subversion: include/private/ libsvn_client/ libsvn_wc/ tests/libsvn_wc/ Message-ID: <4E0346D4.firstname.lastname@example.org> http://svn.haxx.se/dev/archive-2011-06/0727.shtml
Suggested by: julianfoad (the new name 'server-excluded')
* subversion/include/private/svn_wc_private.h (svn_wc__node_is_status_unauthz): Rename to... (svn_wc__node_is_status_server_excluded): ... this, and rename the 'is_unauthz' output parameter to 'is_server_excluded'.
As part of internal API cleanup, and in the name of code clarity, rename svn_wc__db_status_absent to svn_wc__db_status_unauthz (not authorized), because this is what 'absent' really means. Now there is less potential for confusing 'absent' with 'not-present' and 'excluded'.
Discussed on IRC with Julian and Bert (not on dev@, but I still wanted to mention that this wasn't just my own idea).
We considered postponing this step to post-1.7 but Bert pointed out that doing so would unnecessarily make backport merges harder. But note that this does not rename all occurrences of the term 'absent' so we'll have to live with historical baggage in some function names, comments, etc.
Neither does this change the wc.db schema. But I think it would be good to rename the NODES presence value "absent" to "unauthz" as well in a separate step (including a format bump).
Suggested by: julianfoad (the new name 'unauthz')
* subversion/include/private/svn_wc_private.h (svn_wc__node_is_status_absent): Rename to... (svn_wc__node_is_status_unauthz): ... this, and rename the 'is_absent' output parameter to 'is_unauthz'.