Unify some duplicated code before things get out of sync:
* subversion/include/svn_types.h, subversion/libsvn_subr/validate.c (svn_mime_type_is_binary): New function. (svn_mime_type_validate): Renamed from svn_validate_mime_type, so we have a consistent prefix for mime-type stuff now. All callers changed.
* subversion/clients/cmdline/feedback.c (notify): Just call svn_mime_type_is_binary, instead of doing it by hand.
* subversion/libsvn_wc/questions.c (svn_wc_has_binary_prop): Same, and users may apply in person for a refund of the cycles wasted this way.