Unify some duplicated code before things get out of sync:
* subversion/include/svn_types.h, subversion/libsvn_subr/validate.c (svn_mime_type_is_binary): New function. (svn_mime_type_validate): Renamed from svn_validate_mime_type, so we have a consistent prefix for mime-type stuff now. All callers changed.
* subversion/clients/cmdline/feedback.c (notify): Just call svn_mime_type_is_binary, instead of doing it by hand.
* subversion/libsvn_wc/questions.c (svn_wc_has_binary_prop): Same, and users may apply in person for a refund of the cycles wasted this way.
Patch by: Eric Gillespie <email@example.com> (Tweaked by me.)
From: firstname.lastname@example.org Subject: [PATCH] Add Id keyword To: email@example.com Date: Sun, 28 Jul 2002 16:36:02 -0500 --- We've already been through why a customizable, format-string keyword is valuable. Unfortunately, this is post-1.0 because we need a mechanism for the server to send configuration data to the client. In the meantime, this patch will provide the concise Id keyword we're used to from CVS, and provide projects a single place to patch to replace Id with $NetBSD$ or whatever. Not as good as the format-string based keyword, but much easier than CVS.
* subversion/include/svn_types.h (SVN_KEYWORD_ID): New define.
* subversion/include/svn_wc.h (svn_wc_keywords_t): New id member.
* subversion/libsvn_wc/translate.c (time_to_keyword_time): New function. (translate_keyword): Handle the Id keyword.
* doc/handbook/client.texi (Properties): Document the Id keyword.
* subversion/tests/clients/cmdline/trans_tests.py (setup_working_copy, keywords_on, keywords_from_birth): Test Id too.